1. Приветствуем Вас на нашем закрытом форуме для складчиков сайта cmsheaven.org. Если Вы частный вебмастер, фрилансер, владелец малого или среднего бизнеса, представитель студии по разработке сайтов - будем рады видеть Вас в наших рядах экономных людей.
    Регистрация на форуме возможна только после вступления в складчину

Компонент EasySocial ошибка при попытке добавить файл на стену.

Тема в разделе "Вопросы по расширениям Joomla [тех. поддержка]", создана пользователем Sobolev, 6 май 2015.

  1. Sobolev

    Sobolev Cкладчик

    Регистрация:
    6 май 2015
    Сообщения:
    7
    Симпатии:
    2
    Joomla! 3.4.1
    EasySocial PRO v1.3.27
    Не прикрепляется файл на стене(фотографии и остальное прикрепляется).
    Выдаёт ошибку на 99% -Unable to parse server response.
    В личных сообщениях компонента файлы и всё остальное прикрепляются без проблем.
    Проверял настройки сервера и требования для компонента. Всё в порядке.
    Искал похожие темы на офф сайте, но не помогло решение похожих проблем.


    Скрин ошибки + консоль открыта была до загрузки страницы.
    Google Chrome Версия 42.0.2311.90 m
    В joomla стоит отображение ошибок-максимум.
    В .htaccess- php_value display_errors 1
    Ошибка сверху вылетаете при загрузке странице, но этот плагин был включен недавно- после проблем с прикреплением файлов.

    [​IMG]
    #1
  2. Modi34

    Modi34 Свой человек Команда форума

    Регистрация:
    31 окт 2014
    Сообщения:
    2.033
    Симпатии:
    720
    попробуйте для теста поставить везде права 777
    проверьте php логи - там должен быть подробный текст ошибки и где она произошла...
    какой у вас шаблон? из квикстарта или на чистую joomla установлен?
    что за файлы вы прикрепляете - какие расширения и размеры... есть ли файлы которые не загружаются? если есть и это не что-то секретное было бы здорово если бы вы скинули мне этот файл под хайд.
    какая у вас версия php...

    без этих данных помочь вам невозможно
    #2
    Sobolev нравится это.
  3. Sobolev

    Sobolev Cкладчик

    Регистрация:
    6 май 2015
    Сообщения:
    7
    Симпатии:
    2
    Извините, что сразу всё не предоставил.

    Ставил квикстаротом, вот шаблон-http://www.joomforest.com/joomla/templates/jf-connecto
    Файлы любого расширения не прикрепляются на стену и на англ языке, в настройках компонента поставил множество расширений, включая pdf,zip,rar,doc,docx- в личных сообщениях файлы с этими расширениям прикрепляются. Ограничения на размер файлы стоит 128м. В компоненте 10м. В личных сообщения отправляются как и маленькие так и большие файлы.
    Файлы в личном сообщение пробовал pdf.doc.docx.zip,rar прикрепляются. разных размеров и не с одного устройства.
    На стену вообще никакие из выше перечисленных не прикрепляются, независимо от размера. Пробовал много разных файлов. включая пустые.

    Обновил компонент EasySocialv до 1.3.28. Без изменений, ошибки те же.
    Последнее редактирование: 7 май 2015
    #3
    Modi34 нравится это.
  4. Modi34

    Modi34 Свой человек Команда форума

    Регистрация:
    31 окт 2014
    Сообщения:
    2.033
    Симпатии:
    720
    судя по логам проблема в настройке сервера - если перенесете сайт на другой сервер или на локалку этой проблемы не должно быть...
    возможно у вас на сервере настроен PrivateTmp и туда скидываются все файлы.
    я бы рекомендовал бы попробовать добавить пути из логов в open_basedir в php.ini http://kb.mediatemple.net/questions/514/How do I set the path for open_basedir? или через htaccess

    если после переноса для теста на локалку или на другой сервер сайт будет все еще выдавать ошибку при загрузке файлов, то у вас проблема со сборкой joomla + easysocial и я попробую создать у себя похожую и воспроизвести ошибку.
    #4
    Sobolev и modern.po нравится это.
  5. Sobolev

    Sobolev Cкладчик

    Регистрация:
    6 май 2015
    Сообщения:
    7
    Симпатии:
    2
    Пути из логов добавил, но не помогло
    #5
  6. Modi34

    Modi34 Свой человек Команда форума

    Регистрация:
    31 окт 2014
    Сообщения:
    2.033
    Симпатии:
    720
    я бы попробовал отключить open_basedir или перенести на другой сервер или локальный хостинг - тогда мы будем точно знать где ошибка - в настройках сервера или в расширении - я сегодня попробую воспроизвести ошибку и по результатам отпишусь.
    #6
    Sobolev и modern.po нравится это.
  7. Modi34

    Modi34 Свой человек Команда форума

    Регистрация:
    31 окт 2014
    Сообщения:
    2.033
    Симпатии:
    720
    проблема в настройках сервера - я как не пытался не смог воспроизвести у себя ошибку - в компоненте все работает хорошо...
    [​IMG]
    #7
    Sobolev нравится это.
  8. Modi34

    Modi34 Свой человек Команда форума

    Регистрация:
    31 окт 2014
    Сообщения:
    2.033
    Симпатии:
    720
    у меня есть предложение - вы не могли бы запаковать ваш сайт и базу данных в архив и прислать мне ссылку на них под личным хайдом - я у себя поставлю вашу сборку и если ошибка есть исправлю ее, а если нет то вам нужно настраивать сервер - отключать лишние модули php...
    #8
    Sobolev и modern.po нравится это.
  9. Sobolev

    Sobolev Cкладчик

    Регистрация:
    6 май 2015
    Сообщения:
    7
    Симпатии:
    2
    На том же хостинге на другой площадке(и домене) установил easysocail с другим шаблоном. Абсолютно та же ошибка. Написал в тех поддержку хостинга для отключения open_basedir(т.к нету опции редактирования php.ini).(cPanel).
    Проблема упирается точно в хостинг. Но их ответ немного озадачил.
    "Параметр open_basedir включен по умолчанию и не может быть отключен по причинам безопасности на общем хостинге, к сожалению."
    Как ещё можно попробовать решить эту проблему?
    Спасибо за помощь в обнаружении проблемы.
    #9
  10. Modi34

    Modi34 Свой человек Команда форума

    Регистрация:
    31 окт 2014
    Сообщения:
    2.033
    Симпатии:
    720
    проще всего сменить хостинг... так же можно попробовать попросить хостера добавить в исключения опр папки - больше ничего сделать нельзя...
    #10
    modern.po нравится это.
  11. Николай

    Николай Мастер

    Регистрация:
    11 окт 2014
    Сообщения:
    88
    Симпатии:
    77
    Всем привет!

    Такую же проблему обнаружил после обновления джумла и компонента соцсети.
    Была версия Joomla!3.8.10
    Обновлено до Joomla!3.10.3

    EasySocial.
    Была версия: 3.2.24 Установлена версия: 4.0.7

    В логах пишет:
    PHP Parse error: syntax error, unexpected ':', expecting '{' in /***/administrator/components/com_easysocial/includes/vendor/guzzlehttp/guzzle/src/functions.php on line 39

    [​IMG]
    Пока ещё особо не разбирался, просто написал в поддержку.
    Параметр open_basedir есть в настройках, скрин прилагаю.
    [​IMG]
    Решение ещё пока не нашёл, просто откатил назад.
    Последнее редактирование: 14 дек 2021
    #11