1. Приветствуем Вас на нашем закрытом форуме для складчиков сайта cmsheaven.org. Если Вы частный вебмастер, фрилансер, владелец малого или среднего бизнеса, представитель студии по разработке сайтов - будем рады видеть Вас в наших рядах экономных людей.
    Регистрация на форуме возможна только после вступления в складчину

Shaper_kidzy 1.3 (ошибка 1064)

Тема в разделе "Обсуждаем Joomla, шаблоны и расширения к ней", создана пользователем user0170j1new16, 12 дек 2016.

  1. user0170j1new16

    user0170j1new16 Cкладчик

    Регистрация:
    14 июн 2016
    Сообщения:
    15
    Симпатии:
    0
    установил квикстарт. сталкнулся со следующей проблемой:
    При создании нового материала в разделе
    SP Kindergarten: добавляю новые курсы. на сайте появляется модуль статьи. Но при переходе на сам материал выдает следующую ошибку: ошибка 1064
    "
    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND `a`.`enabled` = '1' ORDER BY `a`.`created_on` DESC LIMIT 10' at line 3 SQL=SELECT a.* FROM `#__spkgarten_courses` AS `a` WHERE AND `a`.`enabled` = '1' ORDER BY `a`.`created_on` DESC LIMIT 10
    "
    на примере (ссылка: http://centrobrazovaniya.ru/index.php/obuchenie/kursy)
    Парикмахерское искусство был переделан с предъустановленой статьи и работает. А вот модуль "Юридические услуги" не хочет ставиться. Не по новой, ни переделкой демо статьи... при переходе выдаёт ошибку..

    Подскажите куда копать.
    Ставил разные версии пчп. сейчас 7.0
    Обновил джумлу,
    Исправить базу жал,
    Кеш чистил.

    Помогите пожалуйста!
    #1
  2. user0170j1new16

    user0170j1new16 Cкладчик

    Регистрация:
    14 июн 2016
    Сообщения:
    15
    Симпатии:
    0
    Методом "научного тыка" разобрался, что ошибка появляется, если не прикрепить к курсам преподавателя. Очень странная ошибка. Можно ли её пофиксить?
    #2
  3. user0170j1new16

    user0170j1new16 Cкладчик

    Регистрация:
    14 июн 2016
    Сообщения:
    15
    Симпатии:
    0
    не работают гугл карты. потратил пару дней. Держите ответ) Может кому пригодится))
    Смысл такой. В шаблон зашит старый плагин Sp Page Builder 1.4
    А он сделан до обязательного требования гуглмап о апи.
    Соответственно нет поля апи гуглмап) апи некуда вставлять. разрабы пофиксили.
    Вот ссылка на ответ разрабов с файлами фикса (нижний пост):
    https://www.joomshaper.com/forums/t...ipt-console-for-technical-details#reply-66569

    1) Или вы закидываете с заменой пару файлов (скачанных с ссылки с оф сайта). Тогда открыв сам модуль в странице контактов вы увидите новое поле для апи.
    2) Или ставите сторонний плагин PohaMap :
    http://www.phoca.cz/download/category/38-phoca-maps-plugin
    язык для него:
    http://www.phoca.cz/download/category/37-phoca-maps-component?start=20

    Вот оригинал с оф сайта:
    "
    Hi,
    1) Download
    2) Unzip
    3) Use ftp too to copy 2 php files here:

    templates\shaper_macro\sppagebuilder\addons\gmap

    replace files!!

    4) Go to addon again, and fill Google Map API
    "
    Как тут прицепить файл не знаю. Думаю админы прикрепят к раздачи шаблона сами)
    Всем хорошего настроения!
    #3